VoIP - Inbound Call Issue
Incident Report for DG Technology
Resolved
Our supplier has isolated the fault affecting some inbound calls, and service is fully restored. Apologies for the inconvenience.
Posted Sep 20, 2017 - 17:56 BST
Investigating
We have identified that inbound callers may experience a delay whilst a call being initiated to some numbers, but the call does successfully connect when called. Our upstream supplier is investigating the issue, and we'll update this status when further information becomes available.
Posted Sep 20, 2017 - 16:34 BST